swift3升级后居然不做后向兼容

作者 bluse wang 日期 2017-01-02
swift3升级后居然不做后向兼容

坑死爹了!apple这次升级从系统OS到开发工具,没一个不是到处坑人。

mac os 10,升级后,一插android手机就死机!windows蓝屏,它白屏!

xcode升级至8后,上来就要给我的项目转码!想着我大小也是付费用户。每年都交着会费呢!应该给我的待遇不会差的。

没成想,点完OK后。成百上千个错!错误数量999+!它居然不后向兼容!说好的只是语法变动点的嘛!

我自己的项目代码就算了,当时alamofire,SwiftyJSON 等等,我有数十个第三方cocoapod库,没一个支持到swift3的,当时就慌了神了。

想着我还有SVN。xcode这货对SVN的支持是业余级的。自带的提交麻烦就算了。版本还是老的。搞得我提交次数又少。

现在网上翻了翻,好多人为了稳定还在用着xcode7呢!还是我too young!too simple!

以此纪念我上过apple的当!